PHP 5.3 与 Zend编译

■先说工具

Zend Guard 5.0.1 版本,编译出来的文件,只能在安装了 Zend Optimizer (目前版本3.3.3) 环境下运行。

Zend Guard 5.5.0 以上版本,编译出来的文件,只能在安装了 Zend Guard Loader (目前版本5.5.0)环境下运行。

Zend Guard Loader  是 Zend Optimizer 的代替品,前者只能安装在PHP5.3系列里,后者只能安装在PHP5.2以下系列。

他们下载地址统统在这里:http://www.zend.com/en/products/guard/downloads

 

■换个说法

如果你用的是PHP5.3,那么请用 Zend Guard 5.5 以上版本编译,并且在服务器上安装对饮版本的 Zend Guard Loader。

如果你用的是PHP5.2,那么请用 Zend Guard 5.5 以下版本编译,并且在服务器上安装 Zend Optimizer。

 

■杯具的WAP3组合

如果你用 Linux 主机,那么以上一切OK。

如果你用 Windows + IIS + PHP5.3 以上也一切OK。

如果你用 Windows + Apache + PHP5.3 那么你杯具了……

因为官方提供的 Windows 版本的 Zend Guard Loader 只有VC9版本,也就是说只支持 IIS!

 

■解决方案

要么,等待官网推出 VC6 版本的 Zend Guard Loader。(从这里看,貌似短期内可能性不太大)

要么,放弃 Apache 改用 IIS。

要么,放弃 Windows 改用 Linux。

要么,你放弃编译……

 

转载注明出处:http://hi.baidu.com/phpbuff/blog/item/4cc603cfea5b9e2bf9dc61ca.html

Leave a Reply